纯真首页 - IT - Javascript

jQuery 2.0将不再支持IE 6/7/8

 
日期:2012-6-29
正常  大字体 ]
  jQuery 官方博客 6月 28 日发了一篇博文,文中提到 jQuery 1.8 (正式版)将在一个月内发布,也透露了 jQuery 的部分路线图。以下是部分摘译:正如我们上一篇博文中所说, jQuery 1.8  正经历一次大扫除,来移除不安全、低效、无效、失策的特性。我们已经着手这项工作,以便大家可以构建剔除某些库后更节省的定制版本。这些努力将让大家享用到,你真正所需要的没有多余东东的  jQuery API 。

  既然我们在打扫房子,就该展望一下未来了。其中有件事干扰着我们的憧憬,那就是过时浏览器的” 冤魂”:IE6、IE7、IE8。在过去 10年中,老旧的 IE,一直是Web开发人员的心头刺。总的而言,某些网站来说还有三分之一的用户在用这些浏览器。还有很多用户需要这些网站提供的信息、服务和产品。对于 很多使用 jQuery 的网站来说,忽视这些用户,这不现实也无益处。

  jQuery的具体构想是解决浏览器之间的差异,所以我们不准备放弃我们的本质理念,轻易忽视数百万的还在使用旧版 IE 的活跃网民(不管其原因)。然而我们也想向前迈进,充分体验现代浏览器,尤其是移动市场的份额在增加。

  路线图

  jQuery 1.8 (正式版)将在一个月内发布。下面是我们有关未来两个版本的想法:

  ● jQuery 1.9 (early 2013 ): 我们将移除 1.8 版本中诸多被抨击(deprecated)的接口。其中部分改为插件,或替代的API。还将支持 IE 6/7/8 。

  ● jQuery 1.9.x (ongoing in 2013 and beyond):  这个版本继续修复各种 Bug。

  ● jQuery 2.0 (early 2013, not long after 1.9): 这个版本将和 1.9 版 以前支持相同的 APIs,但不再支持IE 6/7/8 ,比如:事件模型、IE7的 “attroperties” 、HTML5 shims等。

  对于1.9 和 2.0 版,我们的目前是,届时他们支持的 API 集合是可以互换的。当 2.0 版本发布后,你的版本选择很简单,如果你要支持IE 6/7/8,就选择 1.9 版;反之随便选,1.9 和 2.0 版皆可。你也可以使用下面的代码:

  1 2 3 4 5 6 <!--[if lt IE 9]>     <script src="jquery-1.9.0.js"></script> <![endif]--> <!--[if gte IE 9]><!-->     <script src="jquery-2.0.0.js"><</script> <!--<![endif]-->

软件搜索

 
版权所有 Copyright © 2003-2017  纯真网络   联系方式
如有任何问题和建议,请联系我们。EMail: admin@cz88.net
粤ICP备12084360号-2 穗公网监备案证第4401040400001号